libusb: Update to 1.0.22
[openwrt/openwrt.git] / package / libs / libusb / Makefile
index 36156fb6a19631881405a5976e5a9ba22c7c63cb..362d742187bc3adbb0f1373559a85ebe425abcc6 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2010-2013 OpenWrt.org
+# Copyright (C) 2010-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,21 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libusb
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libusb
-PKG_VERSION:=1.0.9
+PKG_VERSION:=1.0.22
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=7f5a02375ad960d4e33a6dae7d63cfcb
-
-PKG_LICENSE:=LGPL-2.1+
-PKG_LICENSE_FILES:=COPYING
+PKG_SOURCE_URL:=https://github.com/libusb/libusb/releases/download/v$(PKG_VERSION)
+PKG_HASH:=75aeb9d59a4fdb800d329a545c2e6799f732362193b465ea198f2aa275518157
 
 PKG_INSTALL:=1
 
 PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
+PKG_BUILD_PARALLEL:=0
 PKG_LICENSE:=LGPL-2.1
 
 PKG_LICENSE:=LGPL-2.1
 
-PKG_MAINTAINER := Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER := Felix Fietkau <nbd@nbd.name>
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,7 +28,7 @@ define Package/libusb-1.0
   CATEGORY:=Libraries
   TITLE:=A library for accessing Linux USB devices
   DEPENDS:=+libpthread +librt
   CATEGORY:=Libraries
   TITLE:=A library for accessing Linux USB devices
   DEPENDS:=+libpthread +librt
-  URL:=http://libusb.wiki.sourceforge.net/
+  URL:=http://libusb.info/
 endef
 
 define Package/libusb-1.0/description
 endef
 
 define Package/libusb-1.0/description
@@ -40,6 +37,9 @@ define Package/libusb-1.0/description
 endef
 
 TARGET_CFLAGS += $(FPIC)
 endef
 
 TARGET_CFLAGS += $(FPIC)
+CONFIGURE_ARGS += \
+       --disable-udev \
+       --disable-log
 
 define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 
 define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/