openssl: add back the CAST cipher by default
[openwrt/openwrt.git] / package / libs / openssl / Makefile
index 393976598b992a49ea9aac8f9f58144fffd25d85..9fbefa581a2b6ad1f6361db5cb5efc23954baa71 100644 (file)
@@ -36,7 +36,8 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_OPENSSL_WITH_DEPRECATED \
        CONFIG_OPENSSL_WITH_COMPRESSION \
        CONFIG_OPENSSL_WITH_NPN \
-       CONFIG_OPENSSL_WITH_PSK
+       CONFIG_OPENSSL_WITH_PSK \
+       CONFIG_OPENSSL_WITH_SRP
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -96,7 +97,7 @@ endef
 
 
 OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-camellia no-krb5 \
- no-whrlpool no-whirlpool no-ripemd no-seed no-cast no-cmac
+ no-whrlpool no-whirlpool no-seed no-cmac
 OPENSSL_OPTIONS:= shared no-err no-sse2 no-ssl2 no-ssl2-method no-heartbeats
 
 ifdef CONFIG_OPENSSL_ENGINE_CRYPTO
@@ -142,6 +143,10 @@ ifndef CONFIG_OPENSSL_WITH_PSK
   OPENSSL_OPTIONS += no-psk
 endif
 
+ifndef CONFIG_OPENSSL_WITH_SRP
+  OPENSSL_OPTIONS += no-srp
+endif
+
 ifeq ($(CONFIG_x86_64),y)
   OPENSSL_TARGET:=linux-x86_64-openwrt
   OPENSSL_MAKEFLAGS += LIBDIR=lib