openssl: Use mkhash for STAMP_CONFIGURED
[openwrt/openwrt.git] / package / libs / openssl / Makefile
index 9b6430234e0a5d8ecf5a82af09118a661c756d96..b39e3c6d7afa0bd6a93e9f07d11f31e3598b28db 100644 (file)
@@ -168,7 +168,7 @@ else
   endif
 endif
 
-STAMP_CONFIGURED := $(STAMP_CONFIGURED)_$(subst $(space),_,$(OPENSSL_OPTIONS))
+STAMP_CONFIGURED := $(STAMP_CONFIGURED)_$(shell echo $(OPENSSL_OPTIONS) | mkhash md5)
 
 define Build/Configure
        [ -f $(STAMP_CONFIGURED) ] || { \