update madwifi to the madwifi-dfs branch - should fix a few ad-hoc mode issues, needs...
[openwrt/openwrt.git] / package / madwifi / Makefile
index 06b3bb6c585eb5ef2d82bd6084e5215c49357cad..117720fa4cd7aaf89b30d3839cc5dc79900896ac 100644 (file)
@@ -10,13 +10,16 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=madwifi
-PKG_VERSION:=r2568-20070710
-PKG_BRANCH:=madwifi-ng
-PKG_RELEASE:=2
+PKG_REV:=2996
+PKG_VERSION:=r$(PKG_REV)
+PKG_BRANCH:=madwifi-dfs
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_BRANCH)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://snapshots.madwifi.org/$(PKG_BRANCH)
-PKG_MD5SUM:=fe5d41acd085d2c46934be3f8839e694
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=$(if $(PKG_BRANCH),$(PKG_BRANCH),madwifi)-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://svn.madwifi.org/madwifi/$(if $(PKG_BRANCH),branches/$(PKG_BRANCH),trunk)
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BRANCH)-$(PKG_VERSION)
 
@@ -31,6 +34,9 @@ endif
 ifeq ($(ARCH),i386)
   HAL_TARGET:=i386-elf
 endif
+ifeq ($(ARCH),i686)
+  HAL_TARGET:=i386-elf
+endif
 ifeq ($(ARCH),armeb)
   HAL_TARGET:=xscale-be-elf
 endif