add preliminary support for Storm SL3512 based devices, not ready yet
[openwrt/openwrt.git] / package / madwifi / Makefile
index f2fdac7b9d7f6a665ad49e2e27cbc558528e2cd5..697f2b68a53a134a5f28d45db5c08a59b6638d39 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -48,6 +48,9 @@ endif
 ifeq ($(ARCH),powerpc)
   HAL_TARGET:=powerpc-be-elf
 endif
+ifeq ($(BOARD),storm)
+  HAL_TARGET:=armv4-le-elf
+endif
 
 ifneq ($(CONFIG_TARGET_atheros),)
   BUS:=AHB
@@ -59,7 +62,7 @@ else
 endif
 
 # XXX: remove this check later when we have PCI support properly detected on all targets
-ifneq ($(CONFIG_TARGET_uml),)
+ifneq ($(CONFIG_TARGET_ar7)$(CONFIG_TARGET_uml),)
  BUS:=
 endif
 
@@ -108,7 +111,7 @@ define KernelPackage/madwifi
   SUBMENU:=Wireless Drivers
   TITLE:=Driver for Atheros wireless chipsets
   URL:=http://madwifi.org/
-  DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_avr32 @!TARGET_etrax @!TARGET_uml
+  DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_ar7 @!TARGET_avr32 @!TARGET_etrax @!TARGET_uml
   FILES:=$(MADWIFI_FILES)
   AUTOLOAD:=$(call AutoLoad,50,$(MADWIFI_AUTOLOAD))
 endef