netifd: update to latest version, fixes various issues related to interface alias...
[openwrt/openwrt.git] / package / netifd / Makefile
index a9b6872b1656cea17884b81369eacc00a56998fd..c54f300ab2fa703f5adca3569f6305ba3dca0853 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_VERSION:=2011-10-27
+PKG_VERSION:=2012-07-05
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/netifd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=3c1a5bf324c8f2476239c4e49687ca252d3bf4c8
+PKG_SOURCE_VERSION:=b4907a8502f0dadda9cdab259e1c824e3522b5b7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 # PKG_MIRROR_MD5SUM:=
 # CMAKE_INSTALL:=1
@@ -18,13 +18,13 @@ include $(INCLUDE_DIR)/cmake.mk
 define Package/netifd
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+libuci +libnl-tiny +libubus +ubus +ubusd +jshn @USE_NETIFD
+  DEPENDS:=+libuci +libnl-tiny +libubus +ubus +ubusd +jshn
   TITLE:=OpenWrt Network Interface Configuration Daemon
 endef
 
 TARGET_CFLAGS += \
-       -I$(STAGING_DIR)/usr/include \
-       -I$(STAGING_DIR)/usr/include/libnl-tiny
+       -I$(STAGING_DIR)/usr/include/libnl-tiny \
+       -I$(STAGING_DIR)/usr/include
 
 CMAKE_OPTIONS += \
        -DLIBNL_LIBS=-lnl-tiny \