lantiq: xrx200: rename nas0/ptm0 to dsl0
[openwrt/openwrt.git] / package / network / config / ltq-vdsl-app / Makefile
index fffe894baf48ad6e4ebfdcd0f1d24766e5622746..baf63f9d1305e0023d530f9df13ec0ca06e24ae6 100644 (file)
@@ -1,5 +1,5 @@
 # Copyright (C) 2010 OpenWrt.org
 # Copyright (C) 2010 OpenWrt.org
-# Copyright (C) 2015 Lantiq Beteiligungs GmbH & Co KG.
+# Copyright (C) 2015-2016 Lantiq Beteiligungs GmbH & Co KG.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,19 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ltq-vdsl-app
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ltq-vdsl-app
-PKG_VERSION:=4.16.6.3
+PKG_VERSION:=4.17.18.6
 PKG_RELEASE:=1
 PKG_BASE_NAME:=dsl_cpe_control
 PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
 PKG_RELEASE:=1
 PKG_BASE_NAME:=dsl_cpe_control
 PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
-PKG_MD5SUM:=8bedf330a456fe0864844e61b57da627
+PKG_HASH:=da8bb929526a61aea0e153ef524331fcd472a1ebbc6d88ca017735a4f82ece02
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BASE_NAME)-$(PKG_VERSION)
 PKG_LICENSE:=BSD-2-Clause
 
 PKG_BUILD_DEPENDS:=kmod-ltq-vdsl-vr9
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BASE_NAME)-$(PKG_VERSION)
 PKG_LICENSE:=BSD-2-Clause
 
 PKG_BUILD_DEPENDS:=kmod-ltq-vdsl-vr9
 
+PKG_FLAGS:=nonshared
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ltq-vdsl-app
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ltq-vdsl-app
@@ -26,7 +28,7 @@ define Package/ltq-vdsl-app
   CATEGORY:=Network
   TITLE:=Lantiq VDSL userland tool
   URL:=http://www.lantiq.com/
   CATEGORY:=Network
   TITLE:=Lantiq VDSL userland tool
   URL:=http://www.lantiq.com/
-  DEPENDS:=@TARGET_lantiq_xrx200 +libpthread +librt +atm-esi
+  DEPENDS:=@TARGET_lantiq_xrx200 +libpthread +librt +ip
 endef
 
 define Package/ltq-vdsl-app/description
 endef
 
 define Package/ltq-vdsl-app/description
@@ -34,37 +36,33 @@ define Package/ltq-vdsl-app/description
 endef
 
 CONFIGURE_ARGS += \
 endef
 
 CONFIGURE_ARGS += \
-       --with-max-device="1" \
-       --with-lines-per-device="1" \
-       --with-channels-per-line="1" \
        --enable-vrx \
        --enable-vrx \
+       --enable-vrx-device=vr9 \
        --enable-driver-include="-I$(STAGING_DIR)/usr/include/drv_vdsl_cpe_api" \
        --enable-device-driver-include="-I$(STAGING_DIR)/usr/include/vdsl/" \
        --enable-driver-include="-I$(STAGING_DIR)/usr/include/drv_vdsl_cpe_api" \
        --enable-device-driver-include="-I$(STAGING_DIR)/usr/include/vdsl/" \
-       --enable-add-appl-cflags="-DMAX_CLI_PIPES=1"  \
        --enable-ifxos \
        --enable-ifxos-include="-I$(STAGING_DIR)/usr/include/ifxos" \
        --enable-ifxos-library="-I$(STAGING_DIR)/usr/lib" \
        --enable-ifxos \
        --enable-ifxos-include="-I$(STAGING_DIR)/usr/include/ifxos" \
        --enable-ifxos-library="-I$(STAGING_DIR)/usr/lib" \
-       --enable-dsl-ceoc=no \
-       --enable-vrx-device=vr9 \
-       --disable-dti \
+       --enable-add-appl-cflags="-DMAX_CLI_PIPES=1"  \
        --enable-debug \
        --enable-debug \
-       --enable-dsl-pm-showtime
-
-ifeq ($(CONFIG_IFX_CLI),y)
-CONFIGURE_ARGS += \
-       --enable-cli-support
-endif
+       --disable-dti \
+       --with-channels-per-line="1" \
 
 #CONFIGURE_ARGS += --enable-model=full
 #CONFIGURE_ARGS += --enable-model=lite
 #CONFIGURE_ARGS += --enable-model=footprint
 
 #CONFIGURE_ARGS += --enable-model=full
 #CONFIGURE_ARGS += --enable-model=lite
 #CONFIGURE_ARGS += --enable-model=footprint
-CONFIGURE_ARGS += --enable-model=typical
+CONFIGURE_ARGS += \
+       --enable-model=typical \
+       --enable-dsl-pm-showtime \
+       --disable-dsl-ceoc
 #CONFIGURE_ARGS += --enable-model=debug
 
 define Package/ltq-vdsl-app/install
 #CONFIGURE_ARGS += --enable-model=debug
 
 define Package/ltq-vdsl-app/install
-       $(INSTALL_DIR) $(1)/etc/init.d $(1)/sbin
+       $(INSTALL_DIR) $(1)/etc/init.d $(1)/sbin $(1)/etc/hotplug.d/dsl $(1)/etc/hotplug.d/net
        $(INSTALL_BIN) ./files/dsl_control $(1)/etc/init.d/
        $(INSTALL_BIN) ./files/dsl_control $(1)/etc/init.d/
-       $(INSTALL_BIN) ./files/vdsl_cpe_control_wrapper $(1)/sbin/
+       $(INSTALL_BIN) ./files/10_atm.sh $(1)/etc/hotplug.d/dsl
+       $(INSTALL_BIN) ./files/10_ptm.sh $(1)/etc/hotplug.d/dsl
+       $(INSTALL_BIN) ./files/10-xdsl_rename $(1)/etc/hotplug.d/net
 
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin/vdsl_cpe_control
        $(INSTALL_BIN) ./files/dsl_cpe_pipe.sh $(1)/sbin/
 
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin/vdsl_cpe_control
        $(INSTALL_BIN) ./files/dsl_cpe_pipe.sh $(1)/sbin/