netifd: update to the latest version
[openwrt/openwrt.git] / package / network / config / netifd / Makefile
index b5f76362ba8cd8f77df3282b814a3d586372a2f1..f80f07a4ff3ac0509b3d4c7db4b6337689cdef41 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
-PKG_SOURCE_DATE:=2021-03-31
-PKG_SOURCE_VERSION:=c84f3b02fced9dd6752a90ca466ada0aabb38224
-PKG_MIRROR_HASH:=d50f1a7983e1e7c0cddfa0642778dfc58a8e62a36f58211928c293d74bd0883b
+PKG_SOURCE_DATE:=2021-07-14
+PKG_SOURCE_VERSION:=7f24a063475e1e2be4e0c516a5b62c3fae5ec542
+PKG_MIRROR_HASH:=3fad25b8655e01e20f54b6c6decad6a660a34ab3ca2de97fe3c9b7db5aa485fe
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 PKG_LICENSE:=GPL-2.0
@@ -27,6 +27,7 @@ endef
 
 define Package/netifd/conffiles
 /etc/udhcpc.user
+/etc/udhcpc.user.d/
 endef
 
 TARGET_CFLAGS += \
@@ -44,6 +45,7 @@ define Package/netifd/install
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/netifd $(1)/sbin/
        $(CP) ./files/* $(1)/
+       $(INSTALL_DIR) $(1)/etc/udhcpc.user.d/
        $(CP) $(PKG_BUILD_DIR)/scripts/* $(1)/lib/netifd/
 endef