treewide: fix shellscript syntax errors/typos
[openwrt/openwrt.git] / package / network / services / hostapd / Makefile
index 207dfecebe46ff1fb5006d5c48bf1c9e137047e6..0e729a83e80c76813e3775dfae3cbd73852a4f95 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=1
+PKG_RELEASE:=5
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
@@ -242,7 +242,7 @@ define Package/eapol-test
   SECTION:=net
   CATEGORY:=Network
   VARIANT:=supplicant-full
-  DEPENDS:=$(DRV_DEPENDS)
+  DEPENDS:=$(DRV_DEPENDS) +WPA_SUPPLICANT_OPENSSL:libopenssl
 endef
 
 
@@ -318,19 +318,19 @@ define Build/Compile/wpad
 endef
 
 define Build/Compile/hostapd
-       $(call Build/RunMake,hostapd, \
+       +$(call Build/RunMake,hostapd, \
                hostapd hostapd_cli \
        )
 endef
 
 define Build/Compile/supplicant
-       $(call Build/RunMake,wpa_supplicant, \
+       +$(call Build/RunMake,wpa_supplicant, \
                wpa_cli wpa_supplicant \
        )
 endef
 
 define Build/Compile/supplicant-full
-       $(call Build/RunMake,wpa_supplicant, \
+       +$(call Build/RunMake,wpa_supplicant, \
                eapol_test \
        )
 endef
@@ -350,7 +350,7 @@ endef
 
 define Package/hostapd-common/install
        $(INSTALL_DIR) $(1)/lib/netifd
-       $(INSTALL_DATA) ./files/netifd.sh $(1)/lib/netifd/hostapd.sh
+       $(INSTALL_DATA) ./files/hostapd.sh $(1)/lib/netifd/hostapd.sh
 endef
 
 define Package/hostapd/install