hostapd: update to version 2016-12-19
[openwrt/openwrt.git] / package / network / services / hostapd / patches / 370-ap_sta_support.patch
index 3a623c45bffae6a0ccea29f9bf84d1fb89dfdd56..03819b33725c399912443e1333c4f60e49a994ac 100644 (file)
@@ -1,6 +1,6 @@
 --- a/wpa_supplicant/wpa_supplicant_i.h
 +++ b/wpa_supplicant/wpa_supplicant_i.h
 --- a/wpa_supplicant/wpa_supplicant_i.h
 +++ b/wpa_supplicant/wpa_supplicant_i.h
-@@ -108,6 +108,11 @@ struct wpa_interface {
+@@ -100,6 +100,11 @@ struct wpa_interface {
        const char *ifname;
  
        /**
        const char *ifname;
  
        /**
@@ -12,8 +12,8 @@
         * bridge_ifname - Optional bridge interface name
         *
         * If the driver interface (ifname) is included in a Linux bridge
         * bridge_ifname - Optional bridge interface name
         *
         * If the driver interface (ifname) is included in a Linux bridge
-@@ -395,6 +400,8 @@ struct wpa_supplicant {
- #endif /* CONFIG_CTRL_IFACE_DBUS_NEW */
+@@ -484,6 +489,8 @@ struct wpa_supplicant {
+ #endif /* CONFIG_CTRL_IFACE_BINDER */
        char bridge_ifname[16];
  
 +      struct wpa_ctrl *hostapd;
        char bridge_ifname[16];
  
 +      struct wpa_ctrl *hostapd;
@@ -23,7 +23,7 @@
  
 --- a/wpa_supplicant/Makefile
 +++ b/wpa_supplicant/Makefile
  
 --- a/wpa_supplicant/Makefile
 +++ b/wpa_supplicant/Makefile
-@@ -13,6 +13,10 @@ PKG_CONFIG ?= pkg-config
+@@ -26,6 +26,10 @@ CFLAGS += $(EXTRA_CFLAGS)
  CFLAGS += -I$(abspath ../src)
  CFLAGS += -I$(abspath ../src/utils)
  
  CFLAGS += -I$(abspath ../src)
  CFLAGS += -I$(abspath ../src/utils)
  
@@ -34,9 +34,9 @@
  -include .config
  -include $(if $(MULTICALL),../hostapd/.config)
  
  -include .config
  -include $(if $(MULTICALL),../hostapd/.config)
  
-@@ -82,6 +86,8 @@ OBJS_c = wpa_cli.o ../src/common/wpa_ctr
- OBJS_c += ../src/utils/wpa_debug.o
- OBJS_c += ../src/utils/common.o
+@@ -115,6 +119,8 @@ OBJS_c += ../src/utils/common.o
+ OBJS_c += ../src/common/cli.o
+ OBJS += wmm_ac.o
  
 +OBJS += ../src/common/wpa_ctrl.o
 +
  
 +OBJS += ../src/common/wpa_ctrl.o
 +
  CONFIG_OS=win32
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
  CONFIG_OS=win32
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
-@@ -105,6 +105,55 @@ const char *wpa_supplicant_full_license5
+@@ -112,6 +112,55 @@ const char *const wpa_supplicant_full_li
  "\n";
  #endif /* CONFIG_NO_STDOUT_DEBUG */
  
 +static int hostapd_stop(struct wpa_supplicant *wpa_s)
 +{
  "\n";
  #endif /* CONFIG_NO_STDOUT_DEBUG */
  
 +static int hostapd_stop(struct wpa_supplicant *wpa_s)
 +{
-+      const char *cmd = "DOWN";
++      const char *cmd = "STOP_AP";
 +      char buf[256];
 +      char buf[256];
-+      int len = sizeof(buf);
++      size_t len = sizeof(buf);
 +
 +      if (wpa_ctrl_request(wpa_s->hostapd, cmd, os_strlen(cmd), buf, &len, NULL) < 0) {
 +              wpa_printf(MSG_ERROR, "\nFailed to stop hostapd AP interfaces\n");
 +
 +      if (wpa_ctrl_request(wpa_s->hostapd, cmd, os_strlen(cmd), buf, &len, NULL) < 0) {
 +              wpa_printf(MSG_ERROR, "\nFailed to stop hostapd AP interfaces\n");
 +{
 +      char *cmd = NULL;
 +      char buf[256];
 +{
 +      char *cmd = NULL;
 +      char buf[256];
-+      int len = sizeof(buf);
++      size_t len = sizeof(buf);
 +      enum hostapd_hw_mode hw_mode;
 +      u8 channel;
 +      int sec_chan = 0;
 +      int ret;
 +
 +      if (!bss)
 +      enum hostapd_hw_mode hw_mode;
 +      u8 channel;
 +      int sec_chan = 0;
 +      int ret;
 +
 +      if (!bss)
-+              return;
++              return -1;
 +
 +      if (bss->ht_param & HT_INFO_HT_PARAM_STA_CHNL_WIDTH) {
 +              int sec = bss->ht_param & HT_INFO_HT_PARAM_SECONDARY_CHNL_OFF_MASK;
 +
 +      if (bss->ht_param & HT_INFO_HT_PARAM_STA_CHNL_WIDTH) {
 +              int sec = bss->ht_param & HT_INFO_HT_PARAM_SECONDARY_CHNL_OFF_MASK;
@@ -84,8 +84,8 @@
 +      }
 +
 +      hw_mode = ieee80211_freq_to_chan(bss->freq, &channel);
 +      }
 +
 +      hw_mode = ieee80211_freq_to_chan(bss->freq, &channel);
-+      if (asprintf(&cmd, "UPDATE channel=%d sec_chan=%d hw_mode=%d ieee80211n=%d",
-+                   channel, sec_chan, hw_mode, !!bss->ht_capab) < 0)
++      if (asprintf(&cmd, "UPDATE channel=%d sec_chan=%d hw_mode=%d",
++                   channel, sec_chan, hw_mode) < 0)
 +              return -1;
 +
 +      ret = wpa_ctrl_request(wpa_s->hostapd, cmd, os_strlen(cmd), buf, &len, NULL);
 +              return -1;
 +
 +      ret = wpa_ctrl_request(wpa_s->hostapd, cmd, os_strlen(cmd), buf, &len, NULL);
  /* Configure default/group WEP keys for static WEP */
  int wpa_set_wep_keys(struct wpa_supplicant *wpa_s, struct wpa_ssid *ssid)
  {
  /* Configure default/group WEP keys for static WEP */
  int wpa_set_wep_keys(struct wpa_supplicant *wpa_s, struct wpa_ssid *ssid)
  {
-@@ -710,8 +759,12 @@ void wpa_supplicant_set_state(struct wpa
- #endif /* CONFIG_P2P */
+@@ -819,8 +868,12 @@ void wpa_supplicant_set_state(struct wpa
+               wpas_p2p_completed(wpa_s);
  
                sme_sched_obss_scan(wpa_s, 1);
 +              if (wpa_s->hostapd)
  
                sme_sched_obss_scan(wpa_s, 1);
 +              if (wpa_s->hostapd)
                wpa_s->new_connection = 1;
                wpa_drv_set_operstate(wpa_s, 0);
  #ifndef IEEE8021X_EAPOL
                wpa_s->new_connection = 1;
                wpa_drv_set_operstate(wpa_s, 0);
  #ifndef IEEE8021X_EAPOL
-@@ -3594,6 +3647,20 @@ static int wpa_supplicant_init_iface(str
+@@ -4790,6 +4843,20 @@ static int wpa_supplicant_init_iface(str
                           sizeof(wpa_s->bridge_ifname));
        }
  
 +      if (iface->hostapd_ctrl) {
                           sizeof(wpa_s->bridge_ifname));
        }
  
 +      if (iface->hostapd_ctrl) {
-+              char *cmd = "DOWN";
++              char *cmd = "STOP_AP";
 +              char buf[256];
 +              int len = sizeof(buf);
 +
 +              char buf[256];
 +              int len = sizeof(buf);
 +
        /* RSNA Supplicant Key Management - INITIALIZE */
        eapol_sm_notify_portEnabled(wpa_s->eapol, FALSE);
        eapol_sm_notify_portValid(wpa_s->eapol, FALSE);
        /* RSNA Supplicant Key Management - INITIALIZE */
        eapol_sm_notify_portEnabled(wpa_s->eapol, FALSE);
        eapol_sm_notify_portValid(wpa_s->eapol, FALSE);
-@@ -3797,6 +3864,11 @@ static void wpa_supplicant_deinit_iface(
+@@ -5083,6 +5150,11 @@ static void wpa_supplicant_deinit_iface(
        if (terminate)
                wpa_msg(wpa_s, MSG_INFO, WPA_EVENT_TERMINATING);
  
        if (terminate)
                wpa_msg(wpa_s, MSG_INFO, WPA_EVENT_TERMINATING);
  
  #include "common/ieee802_11_defs.h"
 +#include "common/ieee802_11_common.h"
  #include "drivers/driver.h"
  #include "common/ieee802_11_defs.h"
 +#include "common/ieee802_11_common.h"
  #include "drivers/driver.h"
+ #include "eap_peer/eap.h"
  #include "wpa_supplicant_i.h"
  #include "wpa_supplicant_i.h"
- #include "config.h"
-@@ -247,6 +248,10 @@ static void calculate_update_time(const 
+@@ -290,6 +291,10 @@ static void calculate_update_time(const
  static void wpa_bss_copy_res(struct wpa_bss *dst, struct wpa_scan_res *src,
                             struct os_reltime *fetch_time)
  {
  static void wpa_bss_copy_res(struct wpa_bss *dst, struct wpa_scan_res *src,
                             struct os_reltime *fetch_time)
  {
        dst->flags = src->flags;
        os_memcpy(dst->bssid, src->bssid, ETH_ALEN);
        dst->freq = src->freq;
        dst->flags = src->flags;
        os_memcpy(dst->bssid, src->bssid, ETH_ALEN);
        dst->freq = src->freq;
-@@ -257,6 +262,15 @@ static void wpa_bss_copy_res(struct wpa_
-       dst->level = src->level;
-       dst->tsf = src->tsf;
+@@ -302,6 +307,15 @@ static void wpa_bss_copy_res(struct wpa_
+       dst->est_throughput = src->est_throughput;
+       dst->snr = src->snr;
  
 +      memset(&elems, 0, sizeof(elems));
 +      ieee802_11_parse_elems((u8 *) (src + 1), src->ie_len, &elems, 0);
  
 +      memset(&elems, 0, sizeof(elems));
 +      ieee802_11_parse_elems((u8 *) (src + 1), src->ie_len, &elems, 0);
  
 --- a/wpa_supplicant/main.c
 +++ b/wpa_supplicant/main.c
  
 --- a/wpa_supplicant/main.c
 +++ b/wpa_supplicant/main.c
-@@ -33,7 +33,7 @@ static void usage(void)
+@@ -34,7 +34,7 @@ static void usage(void)
               "vW] [-P<pid file>] "
               "[-g<global ctrl>] \\\n"
               "        [-G<group>] \\\n"
               "vW] [-P<pid file>] "
               "[-g<global ctrl>] \\\n"
               "        [-G<group>] \\\n"
               "[-p<driver_param>] \\\n"
               "        [-b<br_ifname>] [-e<entropy file>]"
  #ifdef CONFIG_DEBUG_FILE
               "[-p<driver_param>] \\\n"
               "        [-b<br_ifname>] [-e<entropy file>]"
  #ifdef CONFIG_DEBUG_FILE
-@@ -84,6 +84,7 @@ static void usage(void)
- #endif /* CONFIG_DEBUG_LINUX_TRACING */
-       printf("  -t = include timestamp in debug messages\n"
+@@ -74,6 +74,7 @@ static void usage(void)
+              "  -g = global ctrl_interface\n"
+              "  -G = global ctrl_interface group\n"
               "  -h = show this help text\n"
               "  -h = show this help text\n"
-+                 "  -H = connect to a hostapd instance to manage state changes\n"
-              "  -L = show license (BSD)\n"
-              "  -o = override driver parameter for new interfaces\n"
-              "  -O = override ctrl_interface parameter for new interfaces\n"
-@@ -175,7 +176,7 @@ int main(int argc, char *argv[])
++             "  -H = connect to a hostapd instance to manage state changes\n"
+              "  -i = interface name\n"
+              "  -I = additional configuration file\n"
+              "  -K = include keys (passwords, etc.) in debug output\n"
+@@ -201,7 +202,7 @@ int main(int argc, char *argv[])
  
        for (;;) {
                c = getopt(argc, argv,
  
        for (;;) {
                c = getopt(argc, argv,
--                         "b:Bc:C:D:de:f:g:G:hi:I:KLm:No:O:p:P:qsTtuvW");
-+                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLm:No:O:p:P:qsTtuvW");
+-                         "b:Bc:C:D:de:f:g:G:hi:I:KLMm:No:O:p:P:qsTtuvW");
++                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLMm:No:O:p:P:qsTtuvW");
                if (c < 0)
                        break;
                switch (c) {
                if (c < 0)
                        break;
                switch (c) {
-@@ -222,6 +223,9 @@ int main(int argc, char *argv[])
+@@ -248,6 +249,9 @@ int main(int argc, char *argv[])
                        usage();
                        exitcode = 0;
                        goto out;
                        usage();
                        exitcode = 0;
                        goto out;
                        break;
 --- a/wpa_supplicant/bss.h
 +++ b/wpa_supplicant/bss.h
                        break;
 --- a/wpa_supplicant/bss.h
 +++ b/wpa_supplicant/bss.h
-@@ -70,6 +70,10 @@ struct wpa_bss {
-       u8 ssid[32];
+@@ -80,6 +80,10 @@ struct wpa_bss {
+       u8 ssid[SSID_MAX_LEN];
        /** Length of SSID */
        size_t ssid_len;
        /** Length of SSID */
        size_t ssid_len;
-+      /** HT caapbilities */
++      /** HT capabilities */
 +      u16 ht_capab;
 +      /* Five octets of HT Operation Information */
 +      u8 ht_param;
 +      u16 ht_capab;
 +      /* Five octets of HT Operation Information */
 +      u8 ht_param;