ppp: honor LDFLAGS
[openwrt/openwrt.git] / package / network / services / ppp / Makefile
index 6faff4e447c57cfd0415aabbdaee8a4b01e92c70..a4122a4f934470e2d9a0bb72a2cb76708c4da807 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,12 +10,13 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.7
-PKG_RELEASE:=4
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
+PKG_SOURCE_URL:=https://download.samba.org/pub/ppp/
 PKG_MD5SUM:=78818f40e6d33a1d1de68a1551f6595a
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_LICENSE:=BSD-4-Clause
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -190,7 +191,7 @@ define Package/ppp/install
        $(INSTALL_CONF) ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
        $(INSTALL_DATA) ./files/etc/ppp/filter $(1)/etc/ppp/
        $(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
-       ln -sf /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
+       $(LN) /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
        $(INSTALL_DIR) $(1)/lib/netifd/proto
        $(INSTALL_BIN) ./files/ppp.sh $(1)/lib/netifd/proto/
        $(INSTALL_BIN) ./files/lib/netifd/ppp-up $(1)/lib/netifd/