ppp: don't start ppp with IPv6 support if ipv6 is not supported
[openwrt/openwrt.git] / package / network / services / ppp / Makefile
index 6c615cab0b929f5035e782b568b47bbd5ca46a93..b1f1f6895042fa4a7ce9e4b170ccfb5a31057e7a 100644 (file)
@@ -10,13 +10,14 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.7
-PKG_RELEASE:=12
+PKG_RELEASE:=14
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://download.samba.org/pub/ppp/
 PKG_HASH:=02e0a3dd3e4799e33103f70ec7df75348c8540966ee7c948e4ed8a42bbccfb30
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_LICENSE:=BSD-4-Clause
+PKG_CPE_ID:=cpe:/a:samba:ppp
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -177,14 +178,19 @@ $(call Build/Configure/Default,, \
        UNAME_M="$(ARCH)" \
 )
        mkdir -p $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux
-       cp \
+       $(CP) \
                $(LINUX_DIR)/include/linux/compiler.h \
                $(LINUX_DIR)/include/$(LINUX_UAPI_DIR)linux/atm*.h \
                $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
+
+       # Kernel 4.14.9+ only, ignore the exit status of cp in case the file
+       # doesn't exits
+       -$(CP) $(LINUX_DIR)/include/linux/compiler_types.h \
+               $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
 endef
 
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
+TARGET_LDFLAGS += -Wl,--gc-sections -flto -fuse-linker-plugin
 
 MAKE_FLAGS += COPTS="$(TARGET_CFLAGS)" \
                PRECOMPILED_FILTER=1 \