samba: use INSTALL_CONF for the uci file
[openwrt/openwrt.git] / package / network / services / samba36 / Makefile
index ba348387a98227071f1b12bdffdfe8a55a3e1e0a..d440495aff57d7e0ce8ecbd2b7cc202bc8640e26 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
-PKG_VERSION:=3.6.23
-PKG_RELEASE:=1
+PKG_VERSION:=3.6.25
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
        http://ftp.samba.org/pub/samba/stable
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=2f7aee1dc5d31aefcb364600915b31dc
+PKG_MD5SUM:=76da2fa64edd94a0188531e7ecb27c4e
 
-PKG_LICENSE:=GPLv3
+PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=COPYING
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
@@ -35,7 +35,7 @@ define Package/samba36-server
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS server
   URL:=http://www.samba.org/
-  DEPENDS:=+USE_EGLIBC:librt
+  DEPENDS:=+USE_GLIBC:librt
 endef
 
 define Package/samba36-client
@@ -65,6 +65,8 @@ TARGET_CFLAGS += -DMAX_DEBUG_LEVEL=$(CONFIG_PACKAGE_SAMBA_MAX_DEBUG_LEVEL) -D__l
 TARGET_LDFLAGS += -Wl,--gc-sections
 
 CONFIGURE_VARS += \
+       ac_cv_lib_attr_getxattr=no \
+       ac_cv_search_getxattr=no \
        ac_cv_file__proc_sys_kernel_core_pattern=yes \
        libreplace_cv_HAVE_C99_VSNPRINTF=yes \
        libreplace_cv_HAVE_GETADDRINFO=yes \
@@ -103,6 +105,7 @@ CONFIGURE_ARGS += \
        --with-piddir=/var/run \
        --with-privatedir=/etc/samba \
        --with-sendfile-support \
+       --without-acl-support \
        --without-cluster-support \
        --without-ads \
        --without-krb5 \
@@ -120,9 +123,13 @@ CONFIGURE_ARGS += \
 
 MAKE_FLAGS += DYNEXP= PICFLAG= MODULES=
 
+define Package/samba36-server/conffiles
+/etc/config/samba
+endef
+
 define Package/samba36-server/install
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/samba.config $(1)/etc/config/samba
+       $(INSTALL_CONF) ./files/samba.config $(1)/etc/config/samba
        $(INSTALL_DIR) $(1)/etc/samba
        $(INSTALL_DATA) ./files/smb.conf.template $(1)/etc/samba
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/codepages/lowcase.dat $(1)/etc/samba
@@ -132,9 +139,9 @@ define Package/samba36-server/install
        $(INSTALL_BIN) ./files/samba.init $(1)/etc/init.d/samba
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_BIN)/samba_multicall $(1)/usr/sbin
-       ln -sf samba_multicall $(1)/usr/sbin/smbd
-       ln -sf samba_multicall $(1)/usr/sbin/nmbd
-       ln -sf samba_multicall $(1)/usr/sbin/smbpasswd
+       $(LN) samba_multicall $(1)/usr/sbin/smbd
+       $(LN) samba_multicall $(1)/usr/sbin/nmbd
+       $(LN) samba_multicall $(1)/usr/sbin/smbpasswd
 endef
 
 define Package/samba36-client/install