uhttpd: add option for mbedtls
[openwrt/openwrt.git] / package / network / services / uhttpd / Makefile
index d8bcf12bf56ac13d60db4e54f936808099ab109c..da5572b5fe5907192f73fa4271460234657784a3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2013 Jo-Philipp Wich <jow@openwrt.org>
+# Copyright (C) 2010-2015 Jo-Philipp Wich <jow@openwrt.org>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_VERSION:=2014-04-08
+PKG_VERSION:=2015-11-08
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
+PKG_SOURCE_URL=$(OPENWRT_GIT)/project/uhttpd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=a0c33bdbc4873210598acdccb292ff77fb6bf624
+PKG_SOURCE_VERSION:=fe01ef3f52adae9da38ef47926cd50974af5d6b7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_LICENSE:=ISC
 
 PKG_BUILD_DEPENDS = ustream-ssl
 
@@ -32,7 +33,7 @@ endef
 
 define Package/uhttpd
   $(Package/uhttpd/default)
-  DEPENDS:=+libubox
+  DEPENDS:=+libubox +libblobmsg-json +libjson-script
 endef
 
 define Package/uhttpd/description
@@ -53,6 +54,7 @@ define Package/uhttpd-mod-tls
   TITLE+= (TLS plugin)
   DEPENDS:=uhttpd \
        +PACKAGE_uhttpd-mod-tls_polarssl:libustream-polarssl \
+       +PACKAGE_uhttpd-mod-tls_mbedtls:libustream-mbedtls \
        +PACKAGE_uhttpd-mod-tls_cyassl:libustream-cyassl \
        +PACKAGE_uhttpd-mod-tls_openssl:libustream-openssl
 endef
@@ -67,6 +69,9 @@ define Package/uhttpd-mod-tls/config
     prompt "TLS Provider"
     default PACKAGE_uhttpd-mod-tls_polarssl
 
+    config PACKAGE_uhttpd-mod-tls_mbedtls
+      bool "mbedTLS"
+
     config PACKAGE_uhttpd-mod-tls_polarssl
       bool "PolarSSL"
 
@@ -106,6 +111,10 @@ define Package/uhttpd/conffiles
 /etc/uhttpd.key
 endef
 
+ifneq ($(CONFIG_USE_GLIBC),)
+  TARGET_CFLAGS += -D_DEFAULT_SOURCE
+endif
+
 TARGET_LDFLAGS += -lcrypt
 
 CMAKE_OPTIONS = -DTLS_SUPPORT=on