arptables: bump to 2015-05-20
[openwrt/openwrt.git] / package / network / utils / arptables / Makefile
index 46006727eb6df86b599552ba83937d345ba76462..1ed0287ca21c1604dfa99f7e265b6b7a2ae9b994 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,14 +7,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=arptables
-PKG_VERSION:=0.0.4
+PKG_VERSION:=2015-05-20
 PKG_RELEASE:=1
+PKG_MIRROR_MD5SUM:=736c2a88f99936811d80dd75d3016c3829ebb9dac8b28ced020a0bee149c2a31
 
-PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/ebtables
-PKG_MD5SUM:=c2e99c3aa9d78c9dfa30710ca3168182
+PKG_SOURCE_URL:=git://git.netfilter.org/arptables
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=f4ab8f63f11a72f14687a6646d04ae1bae3fa45f
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
+PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,15 +27,12 @@ define Package/arptables
   SUBMENU:=Firewall
   TITLE:=ARP firewalling software
   DEPENDS:=+kmod-arptables
-  URL:=http://ebtables.sourceforge.net
+  URL:=https://git.netfilter.org/arptables/
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               COPT_FLAGS="$(TARGET_CFLAGS)" \
-               KERNEL_DIR="./include/linux"
-endef
+MAKE_FLAGS += \
+       COPT_FLAGS="$(TARGET_CFLAGS) -D__OPTIMIZE__=1" \
+       KERNEL_DIR="$(LINUX_DIR)"
 
 define Package/arptables/install
        $(INSTALL_DIR) $(1)/usr/sbin