conntrack-tools: update to v1.4.4
[openwrt/openwrt.git] / package / network / utils / conntrack-tools / Makefile
index 2c479c0849c18d4edad8e00e8c2c5bc130f1d17e..95257c6c67582836cf0ab7184fdb54af89c9b5aa 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=conntrack-tools
-PKG_VERSION:=1.4.2
+PKG_VERSION:=1.4.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -16,53 +16,65 @@ PKG_SOURCE_URL:= \
        http://www.netfilter.org/projects/conntrack-tools/files \
        ftp://ftp.netfilter.org/pub/conntrack-tools \
        http://mirrors.evolva.ro/netfilter.org/conntrack-tools
-PKG_MD5SUM:=b1f9d006e7bf000a77395ff7cd3fac16
+PKG_MD5SUM:=b7caf4fcc4c03575df57d25e5216584d597fd916c891f191dac616ce68bdba6c
 
-PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=GPL-2.0
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
-TAR_OPTIONS += --exclude='*.rej'
-
 PKG_BUILD_DEPENDS:=librpc
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/conntrack-tools
+define Package/conntrack-tools/default
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libnetfilter-conntrack +libnetfilter-cttimeout +libnetfilter-cthelper +libnetfilter-queue
   SUBMENU:=Firewall
-  TITLE:=Connection tracking userspace tools
   URL:=http://conntrack-tools.netfilter.org/
 endef
 
-define Package/conntrack-tools/description
- The conntrack-tools are a set of free software userspace tools for Linux
- that allow system administrators interact with the Connection Tracking
- System, which is the module that provides stateful packet inspection for
- iptables. The conntrack-tools are the userspace daemon conntrackd and the
- command line interface conntrack.
+define Package/conntrack
+$(call Package/conntrack-tools/default)
+  TITLE:=Connection tracking tool
 endef
 
-define Package/conntrack-tools/conffiles
-/etc/conntrackd/conntrackd.conf
+define Package/conntrack/description
+ Conntrack is a userspace command line program targeted at system
+ administrators. It enables them to view and manage the in-kernel
+ connection tracking state table.
 endef
 
-TARGET_CFLAGS += -D_GNU_SOURCE=1
-
-define Package/conntrack-tools/install
-       $(INSTALL_DIR) $(1)/etc/conntrackd
-       $(INSTALL_CONF) \
-               $(PKG_BUILD_DIR)/doc/stats/conntrackd.conf \
-               $(1)/etc/conntrackd/
+define Package/conntrack/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) \
-               $(PKG_INSTALL_DIR)/usr/sbin/conntrack \
-               $(PKG_INSTALL_DIR)/usr/sbin/conntrackd \
-               $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/conntrack $(1)/usr/sbin/
+endef
+
+define Package/conntrackd
+$(call Package/conntrack-tools/default)
+  TITLE:=Connection tracking daemon
+endef
+
+define Package/conntrackd/conffiles
+/etc/conntrackd/
+endef
+
+define Package/conntrackd/description
+ Conntrackd can replicate the status of the connections that are
+ currently being processed by your stateful firewall based on Linux.
+ Conntrackd can also run as statistics daemon.
+endef
+
+define Package/conntrackd/install
+       $(INSTALL_DIR) \
+               $(1)/etc/conntrackd \
+               $(1)/etc/init.d \
+               $(1)/usr/sbin
+       $(INSTALL_BIN)  $(PKG_INSTALL_DIR)/usr/sbin/conntrackd $(1)/usr/sbin/
+       $(INSTALL_BIN) ./files/conntrackd.init $(1)/etc/init.d/conntrackd
 endef
 
-$(eval $(call BuildPackage,conntrack-tools))
+$(eval $(call BuildPackage,conntrack))
+$(eval $(call BuildPackage,conntrackd))