ipset: split libipset as a subpackage
[openwrt/openwrt.git] / package / network / utils / iperf / Makefile
index a5067ecc2d1ef6bf6c859e0fc35059fe36b97041..ea8f026315e530ad7a7f7f6403f9c455898d41f6 100644 (file)
@@ -8,84 +8,49 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iperf
-PKG_VERSION:=2.0.5
+PKG_VERSION:=2.0.9
+PKG_VERSION_SUFFIX:=a
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=44b5536b67719f4250faed632a3cd016
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)$(PKG_VERSION_SUFFIX).tar.gz
+# Temporary URL change - iperf upstream altered the already released target
+# without bumping the version number. The new tarball is renamed to avoid
+# conflicts with existing mirrored files.
+# PKG_SOURCE_URL:=@SF/iperf2
+PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_HASH:=db02911f35686e808ed247160dfa766e08ae3f59d1e7dcedef0ffb2a6643f0bf
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_LICENSE:=BSD-3-Clause
 
-PKG_LICENSE:=NCSA
-PKG_LICENSE_FILES:=COPYING
-
 PKG_BUILD_PARALLEL:=1
-PKG_CHECK_FORMAT_SECURITY:=0
 
 include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
-define Package/iperf/Default
+define Package/iperf
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:= $(CXX_DEPENDS)
+  DEPENDS:= $(CXX_DEPENDS) +libpthread
   TITLE:=Internet Protocol bandwidth measuring tool
-  URL:=http://sourceforge.net/projects/iperf/
+  URL:=http://sourceforge.net/projects/iperf2/
 endef
 
-define Package/iperf/Default/description
+define Package/iperf/description
  Iperf is a modern alternative for measuring TCP and UDP bandwidth
  performance, allowing the tuning of various parameters and
  characteristics.
 endef
 
-define Package/iperf
-$(call Package/iperf/Default)
-  TITLE+= (with single thread support)
-  VARIANT:=single
-endef
-
-define Package/iperf/description
-$(call Package/iperf/Default/description)
- This package is built with single thread support.
-endef
-
-define Package/iperf-mt
-$(call Package/iperf/Default)
-  DEPENDS+= +libpthread
-  TITLE+= (with multithread support)
-  VARIANT:=mt
-endef
-
-define Package/iperf-mt/description
-$(call Package/iperf/Default/description)
- This package is built with multithread support.
-endef
-
+TARGET_CFLAGS += -D_GNU_SOURCE
 CONFIGURE_ARGS += --disable-multicast
-CONFIGURE_VARS += ac_cv_func_malloc_0_nonnull=yes
-
-ifeq ($(BUILD_VARIANT),single)
-  CONFIGURE_ARGS += --disable-threads
-else
-  CONFIGURE_ARGS += --enable-threads=posix
-  CONFIGURE_VARS += ac_cv_func_pthread_cancel=no
-endif
 
 CONFIGURE_VARS += CXXFLAGS="$$$$CXXFLAGS -fno-rtti"
-
-ifeq ($(BUILD_VARIANT),mt)
-  CONFIGURE_VARS += LIBS="-lpthread"
-endif
+CONFIGURE_VARS += LIBS="-lpthread -lm"
 
 define Package/iperf/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/iperf $(1)/usr/bin/iperf
 endef
-Package/iperf-mt/install = $(Package/iperf/install)
 
 $(eval $(call BuildPackage,iperf))
-$(eval $(call BuildPackage,iperf-mt))