license info - revert r43155
[openwrt/openwrt.git] / package / network / utils / iproute2 / Makefile
index 7cc2fb43c760fe9490bacb8900a3466a4070571d..f6d2801e53883863833ea4532d924cb4e2a69339 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=3.11.0
+PKG_VERSION:=3.16.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
-PKG_MD5SUM:=d7ffb27bc9f0d80577b1f3fb9d1a7689
+PKG_MD5SUM:=6c823b40fdcfa7b8120743349a52ac18
 PKG_BUILD_PARALLEL:=1
+PKG_LICENSE:=GPL-2.0
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -24,13 +25,18 @@ define Package/iproute2/Default
   TITLE:=Routing control utility ($(2))
   SECTION:=net
   CATEGORY:=Network
-  URL:=http://linux-net.osdl.org/index.php/Iproute2
+  URL:=http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
   SUBMENU:=Routing and Redirection
+  MAINTAINER:=Russell Senior <russell@personaltelco.net>
   DEPENDS:= +libnl-tiny
   VARIANT:=$(1)
 endef
 
-Package/ip=$(call Package/iproute2/Default,tiny,Minimal)
+define Package/ip
+$(call Package/iproute2/Default,tiny,Minimal)
+  CONFLICTS:=ip-full
+endef
+
 Package/ip-full=$(call Package/iproute2/Default,full,Full)
 
 define Package/ip/conffiles
@@ -76,6 +82,9 @@ ifdef CONFIG_USE_EGLIBC
     TARGET_CFLAGS += -DHAVE_SETNS
   endif
 endif
+ifdef CONFIG_USE_MUSL
+  TARGET_CFLAGS += -DHAVE_SETNS
+endif
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 
@@ -85,7 +94,7 @@ MAKE_FLAGS += \
        SHARED_LIBS="" \
        LDFLAGS="-Wl,--gc-sections" \
        IP_CONFIG_TINY=$(IP_CONFIG_TINY) \
-       FPIC=""
+       FPIC="$(FPIC)"
 
 define Build/Compile
        +$(MAKE_VARS) $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS)