iptables: fix dependency for libip6tc on IPV6
[openwrt/openwrt.git] / package / network / utils / iptables / Makefile
index 1d758ed07d720f6d6bd974d96ba54b9609b5173b..c1e4790d11a1a138a0ed819685096f9e1f137fc9 100644 (file)
@@ -150,6 +150,7 @@ Includes support for:
 
  Matches:
   - string
+  - bpf
 
 endef
 
@@ -461,7 +462,7 @@ define Package/libiptc
 $(call Package/iptables/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libip4tc +libip6tc +libxtables
+  DEPENDS:=+libip4tc +IPV6:libip6tc +libxtables
   ABI_VERSION:=$(PKG_VERSION)
   TITLE:=IPv4/IPv6 firewall - shared libiptc library (compatibility stub)
 endef
@@ -481,7 +482,7 @@ $(call Package/iptables/Default)
   CATEGORY:=Libraries
   TITLE:=IPv6 firewall - shared libiptc library
   ABI_VERSION:=$(PKG_VERSION)
-  DEPENDS:=+libxtables
+  DEPENDS:=@IPV6 +libxtables
 endef
 
 define Package/libxtables