iptables: fix dependency for libip6tc on IPV6
[openwrt/openwrt.git] / package / network / utils / iptables / Makefile
index d70dc11d45185f63a767964ca743ca92d7b93f8f..c1e4790d11a1a138a0ed819685096f9e1f137fc9 100644 (file)
@@ -18,6 +18,7 @@ PKG_SOURCE_VERSION:=c16bdec15137b241586310d0e61bc88cc3726004
 PKG_MIRROR_HASH:=72e4bec94a56dd600097846c773e1074ff705e38f800ef221db646c064371a53
 
 PKG_FIXUP:=autoreconf
+PKG_FLAGS:=nonshared
 
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
@@ -149,6 +150,7 @@ Includes support for:
 
  Matches:
   - string
+  - bpf
 
 endef
 
@@ -460,7 +462,7 @@ define Package/libiptc
 $(call Package/iptables/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libip4tc +libip6tc +libxtables
+  DEPENDS:=+libip4tc +IPV6:libip6tc +libxtables
   ABI_VERSION:=$(PKG_VERSION)
   TITLE:=IPv4/IPv6 firewall - shared libiptc library (compatibility stub)
 endef
@@ -480,7 +482,7 @@ $(call Package/iptables/Default)
   CATEGORY:=Libraries
   TITLE:=IPv6 firewall - shared libiptc library
   ABI_VERSION:=$(PKG_VERSION)
-  DEPENDS:=+libxtables
+  DEPENDS:=@IPV6 +libxtables
 endef
 
 define Package/libxtables