openssl: add a patch to fix link segfault when using a glibc/eglibc based toolchain...
[openwrt/openwrt.git] / package / openssl / Makefile
index 6eafc7ed7d71239c404dd745fa5664c0ac9a1d7d..a2de0e0ca44dddb94f9a856ea8f95c1a27e571ce 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=0.9.8h
+PKG_VERSION:=0.9.8j
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -17,7 +17,9 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
        ftp://ftp.webmonster.de/pub/openssl/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=7d3d41dafc76cf2fcb5559963b5783b3
+PKG_MD5SUM:=a5cb5f6c3d11affb387ecf7a997cac0c
+
+PKG_BUILD_DEPENDS:=ocf-crypto-headers
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,9 +29,9 @@ define Package/openssl/Default
 endef
 
 define Package/openssl/Default/description
- The OpenSSL Project is a collaborative effort to develop a robust, 
- commercial-grade, full-featured, and Open Source toolkit implementing the 
- Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) 
+ The OpenSSL Project is a collaborative effort to develop a robust,
+ commercial-grade, full-featured, and Open Source toolkit implementing the
+ Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  protocols as well as a full-strength general purpose cryptography library.
 endef
 
@@ -43,7 +45,7 @@ endef
 
 define Package/libopenssl/description
 $(call Package/openssl/Default/description)
- This package contains the OpenSSL shared libraries, needed by other 
+ This package contains the OpenSSL shared libraries, needed by other
  programs.
 endef
 
@@ -65,13 +67,13 @@ $(call Package/openssl/Default/description)
 endef
 
 
-OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
+OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
                                        no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
 ifeq ($(BOARD),ixp4xx)
-OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
-                                       no-sse2 no-perlasm
+OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic \
+                                       no-sse2 no-perlasm --with-cryptodev
 else
-OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic \
                                        no-engines no-sse2 no-perlasm
 endif
 
@@ -89,6 +91,8 @@ define Build/Configure
        )
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
@@ -120,7 +124,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
        mkdir -p $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
-       $(SED) 's,$(TARGET_LDFLAGS),,g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+       $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
 endef
 
 define Package/libopenssl/install