openssl: use assembler version of aes on arm - nearly doubles aes encryption performance
[openwrt/openwrt.git] / package / openssl / Makefile
index e064631e67842f694adad316958658807a6e534b..ac565218da10f6663faf2e53c75c6ffa2471837d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=0.9.8k
+PKG_VERSION:=0.9.8l
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
        ftp://ftp.webmonster.de/pub/openssl/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=e555c6d58d276aec7fdc53363e338ab3
+PKG_MD5SUM:=05a0ece1372392a2cf310ebb96333025
 
 PKG_BUILD_DEPENDS:=ocf-crypto-headers
 
@@ -37,6 +37,7 @@ endef
 define Package/libopenssl
 $(call Package/openssl/Default)
   SECTION:=libs
+  SUBMENU:=SSL
   CATEGORY:=Libraries
   DEPENDS:=+zlib
   TITLE+= (libraries)
@@ -70,12 +71,16 @@ OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
                                        no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
 ifeq ($(BOARD),ixp4xx)
 OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic \
-                                       no-sse2 no-perlasm --with-cryptodev
+                                       no-sse2 --with-cryptodev
 else
 OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic \
-                                       no-engines no-sse2 no-perlasm
+                                       no-engines no-sse2
+endif
+ifdef CONFIG_arm
+OPENSSL_MAKEFLAGS := AES_ASM_OBJ="aes-armv4.o aes_cbc.o"
+else
+OPENSSL_OPTIONS += no-perlasm
 endif
-
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
@@ -93,26 +98,31 @@ endef
 TARGET_CFLAGS += $(FPIC)
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
+       # XXX: OpenSSL "make depend" will look for installed headers before its own,
+       # so remove installed stuff first
+       -$(SUBMAKE) -j1 clean-staging
        $(MAKE) -C $(PKG_BUILD_DIR) \
                MAKEDEPPROG="$(TARGET_CROSS)gcc" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
+               $(OPENSSL_MAKEFLAGS) \
                depend
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                AR="$(TARGET_CROSS)ar r" \
                RANLIB="$(TARGET_CROSS)ranlib" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
+               $(OPENSSL_MAKEFLAGS) \
                all build-shared
        # Work around openssl build bug to link libssl.so with libcrypto.so.
        -rm $(PKG_BUILD_DIR)/libssl.so.*.*.*
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
+               $(OPENSSL_MAKEFLAGS) \
                do_linux-shared
        $(MAKE) -C $(PKG_BUILD_DIR) \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
+               $(OPENSSL_MAKEFLAGS) \
                install
 endef
 
@@ -128,8 +138,8 @@ endef
 
 define Package/libopenssl/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.so.* $(1)/usr/lib/
-       chmod 0644 $(1)/usr/lib/*
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libcrypto.so.* $(1)/usr/lib/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libssl.so.* $(1)/usr/lib/
 endef
 
 define Package/openssl-util/install