Use $(CP) instead of $(INSTALL_BIN) for binaries.
[openwrt/openwrt.git] / package / pcmcia-cs / Makefile
index 78419de75d49f9818e46bc08e04fb65aea61b1b8..af9c755c1d29642c457939994e00983c43be43e6 100644 (file)
@@ -7,6 +7,7 @@
 # $Id$
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=pcmcia-cs
 PKG_VERSION:=3.2.8
@@ -15,21 +16,19 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 PKG_MD5SUM:=0d6d65be8896eff081aee996049afaa5
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pcmcia-cs
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@PCMCIA_SUPPORT
+  DEPENDS:=@LINUX_2_4 @PCMCIA_SUPPORT
   TITLE:=PCMCIA/Cardbus management utilities
   URL:=http://pcmcia-cs.sourceforge.net/
 endef
 
+$(STAMP_CONFIGURED): $(LINUX_DIR)/.config
+
 define Build/Configure
        ( cd $(PKG_BUILD_DIR); \
                ./Configure \
@@ -51,6 +50,8 @@ define Build/Configure
 endef
 
 define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS)" \
                all install \
@@ -58,11 +59,11 @@ define Build/Compile
 endef
 
 define Package/pcmcia-cs/install
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/pcmcia $(1)/etc/
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/sbin/cardctl $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/cardmgr $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/cardctl $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/cardmgr $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,pcmcia-cs))