ppp: quote positional parameters when calling up/down scripts (closes: #5622)
[openwrt/openwrt.git] / package / ppp / Makefile
index f6dbd33c95e8e1dc1b3c0eff1103d0f6b557f059..919e105bbb71b3da82ba65c3a9695f8710db8afb 100644 (file)
@@ -1,20 +1,19 @@
-# 
-# Copyright (C) 2006-2008 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ppp
-PKG_VERSION:=2.4.3
-PKG_RELEASE:=10
+PKG_VERSION:=2.4.4
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
-PKG_MD5SUM:=848f6c3cafeb6074ffeb293c3af79b7c
+PKG_MD5SUM:=183800762e266132218b204dfb428d29
 
 PKG_BUILD_DEPENDS:=libpcap
 
@@ -121,6 +120,11 @@ define Build/Compile
                all install
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/pppd $(1)/usr/include/
+endef
+
 define Package/ppp/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
        $(INSTALL_DIR) $(1)/usr/sbin