opkg: switch source url to git.openwrt.org
[openwrt/openwrt.git] / package / system / opkg / Makefile
index f660f64acebda810dfef9b10c730e55af5c84bf6..f00e574de08d0f22d12b03895341c41f2a020933 100644 (file)
@@ -7,33 +7,26 @@
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
-include $(INCLUDE_DIR)/version.mk
-include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=opkg
 
 PKG_NAME:=opkg
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_FLAGS:=essential
 
 PKG_SOURCE_PROTO:=git
 PKG_FLAGS:=essential
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://git.lede-project.org/project/opkg-lede.git
-PKG_SOURCE_DATE:=2017-07-11
-PKG_SOURCE_VERSION:=52fc0069b50b9be89ae3b525b98741123461dd0a
-PKG_MIRROR_HASH:=f7b0ea689b6e3f1cf680514bd59b13d9cd33c8255056b49af85e512554f97ccf
+PKG_SOURCE_URL:=https://git.openwrt.org/project/opkg-lede.git
+PKG_SOURCE_DATE:=2017-12-07
+PKG_SOURCE_VERSION:=3b417b9f41b4ceb5912d82f867dd5534e5675b5c
+PKG_MIRROR_HASH:=1c9c21e56186345d0034d15051c1d9c5ebb5aa6658d6ae8886d8403207a914a3
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 
-PKG_FLAGS := nonshared
-
-PKG_CONFIG_DEPENDS := \
+# Extend depends from version.mk
+PKG_CONFIG_DEPENDS += \
        CONFIG_SIGNED_PACKAGES \
        CONFIG_SIGNED_PACKAGES \
-       CONFIG_TARGET_INIT_PATH \
-       CONFIG_PER_FEED_REPO \
-       CONFIG_PER_FEED_REPO_ADD_DISABLED \
-       CONFIG_PER_FEED_REPO_ADD_COMMENTED \
-       $(foreach feed,$(FEEDS_INSTALLED),CONFIG_FEED_$(feed))
+       CONFIG_TARGET_INIT_PATH
 
 PKG_BUILD_PARALLEL:=1
 HOST_BUILD_PARALLEL:=1
 
 PKG_BUILD_PARALLEL:=1
 HOST_BUILD_PARALLEL:=1
@@ -50,7 +43,7 @@ define Package/opkg
   CATEGORY:=Base system
   TITLE:=opkg package manager
   DEPENDS:=+uclient-fetch +libpthread +libubox
   CATEGORY:=Base system
   TITLE:=opkg package manager
   DEPENDS:=+uclient-fetch +libpthread +libubox
-  URL:=https://git.lede-project.org/?p=project/opkg-lede.git
+  URL:=$(PKG_SOURCE_URL)
   MENU:=1
 endef
 
   MENU:=1
 endef
 
@@ -93,8 +86,6 @@ define Package/opkg/install
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_DATA) ./files/customfeeds.conf $(1)/etc/opkg/customfeeds.conf
        $(INSTALL_DATA) ./files/opkg$(2).conf $(1)/etc/opkg.conf
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_DATA) ./files/customfeeds.conf $(1)/etc/opkg/customfeeds.conf
        $(INSTALL_DATA) ./files/opkg$(2).conf $(1)/etc/opkg.conf
-       $(call FeedSourcesAppend,$(1)/etc/opkg/distfeeds.conf)
-       $(VERSION_SED) $(1)/etc/opkg/distfeeds.conf
        $(INSTALL_BIN) ./files/20_migrate-feeds $(1)/etc/uci-defaults/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
   ifneq ($(CONFIG_SIGNED_PACKAGES),)
        $(INSTALL_BIN) ./files/20_migrate-feeds $(1)/etc/uci-defaults/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
   ifneq ($(CONFIG_SIGNED_PACKAGES),)