procd: update to latest version, fixes a format string bug in processing init script...
[openwrt/openwrt.git] / package / system / procd / Makefile
index f75aa26a1e6e2ba06bd1616a16695b85f7f3a5f0..2c7158dd7cba891bcc9317418e3c0de01960b438 100644 (file)
@@ -1,13 +1,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2013-06-27
+PKG_VERSION:=2014-03-18
+
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=0d44f0de9eacf687182ebebfcb1f9496dbf3bc32
+PKG_SOURCE_VERSION:=7a9cbcd88b6cf3c0cbee6d4f76c2adaedc54058d
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
@@ -24,17 +25,17 @@ TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
 define Package/procd
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt
+  DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt +libubox
   TITLE:=OpenWrt system process manager
 endef
 
 define Package/procd/install
-       $(INSTALL_DIR) $(1)/sbin $(1)/lib/functions $(1)/etc
+       $(INSTALL_DIR) $(1)/sbin  $(1)/etc $(1)/lib/functions
 
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{procd,askfirst,udevtrigger,logread} $(1)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{init,procd,askfirst,udevtrigger} $(1)/sbin/
+       $(INSTALL_BIN) ./files/reload_config $(1)/sbin/
        $(INSTALL_DATA) ./files/hotplug*.json $(1)/etc/
        $(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
-       ln -s /sbin/procd $(1)/sbin/init
 endef
 
 $(eval $(call BuildPackage,procd))