update libubox and ubus to the latest version
[openwrt/openwrt.git] / package / ubus / Makefile
index 39c7ba8134ad893ca2e294dabc28dd58581bcb44..ae0fc040d3093df22a3d43af830ac5705bb402c0 100644 (file)
@@ -1,14 +1,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ubus
-PKG_VERSION:=2011-02-11
-PKG_RELEASE:=1
+PKG_VERSION:=2011-09-14
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/ubus.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=f2ee96c51d38363092415cc333f8f7a62f16783a
+PKG_SOURCE_VERSION:=f86ec180c049f3344d18a2675ce95cdf7a7e62b7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_MIRROR_MD5SUM:=365bbaa3e6e72c7d417ee6b095cd8461
 CMAKE_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -18,7 +19,7 @@ define Package/ubus
   SECTION:=luci2
   CATEGORY:=LuCI2
   SUBMENU:=System
-  DEPENDS:=+libubus +ubusd
+  DEPENDS:=+libubus +libblobmsg-json +ubusd
   TITLE:=OpenWrt RPC client utility
 endef