busybox: fix installation of cron and ntpd scripts in the default config
[openwrt/openwrt.git] / package / utils / busybox / Makefile
index 6463dc0184f1f857c27edfa26ffdd5b70d0bfe23..0d370863653e280165c8083061799af97d031169 100644 (file)
@@ -118,10 +118,10 @@ endef
 define Package/busybox/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
-ifneq ($(CONFIG_BUSYBOX_CONFIG_CROND),)
+ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_CROND),)
        $(INSTALL_BIN) ./files/cron $(1)/etc/init.d/cron
 endif
-ifneq ($(CONFIG_BUSYBOX_CONFIG_NTPD),)
+ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_NTPD),)
        $(INSTALL_BIN) ./files/sysntpd $(1)/etc/init.d/sysntpd
        $(INSTALL_BIN) ./files/ntpd-hotplug $(1)/usr/sbin/ntpd-hotplug
 endif