busybox: drop providing virtual package ip
[openwrt/openwrt.git] / package / utils / busybox / Makefile
index 54ad986e66a75bd8e1e76baf81725a924cd59356..623fbd5896f98ab0c4f0118b6e41d4eaae5f8e1a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.27.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -22,6 +22,9 @@ PKG_BUILD_PARALLEL:=1
 PKG_CHECK_FORMAT_SECURITY:=0
 PKG_INSTALL:=1
 
+#Busybox use it's own PIE config flag and LDFLAGS are used with ld, not gcc.
+PKG_ASLR_PIE:=0
+
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=LICENSE archival/libarchive/bz/LICENSE
 PKG_CPE_ID:=cpe:/a:busybox:busybox
@@ -43,7 +46,6 @@ define Package/busybox
   URL:=http://busybox.net/
   DEPENDS:=+BUSYBOX_USE_LIBRPC:librpc +BUSYBOX_CONFIG_PAM:libpam +BUSYBOX_CONFIG_NTPD:jsonfilter
   MENU:=1
-  PROVIDES:=ip
   ALTERNATIVES:=\
     $(call BUSYBOX_IF_ENABLED,KILL,    100:/bin/kill:/bin/busybox) \
     $(call BUSYBOX_IF_ENABLED,PS,      100:/bin/ps:/bin/busybox) \
@@ -83,7 +85,8 @@ endif
 
 MAKE_VARS :=
 MAKE_FLAGS += \
-       EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+       EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+       EXTRA_LDFLAGS="$(TARGET_LDFLAGS)" \
        LDLIBS="$(LDLIBS)" \
        SKIP_STRIP=y
 ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)