busybox: keep syslog.conf during sysupgrade
[openwrt/openwrt.git] / package / utils / busybox / Makefile
index 0eaec1993860910fca36d51b143843e871f15398..dbc5dee62cb4b5142821e16d813bd5ae3a4d839e 100644 (file)
@@ -73,6 +73,12 @@ define Package/busybox/config
        source "$(SOURCE)/Config.in"
 endef
 
+ifdef CONFIG_BUSYBOX_CONFIG_FEATURE_SYSLOG
+define Package/busybox/conffiles
+/etc/syslog.conf
+endef
+endif
+
 # don't create a version string containing the actual timestamp
 export KCONFIG_NOTIMESTAMP=1