fix wlcompat defaults
[openwrt/openwrt.git] / package / wlcompat / Makefile
index fc66c90f506304c8e49835a5085143e1cd66dda6..ceb5969d9220ee339dbd2ac061d3508104bb239b 100644 (file)
@@ -19,7 +19,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/kmod-wlcompat/Default
   SECTION:=kernel
   CATEGORY:=Kernel drivers
-  DEPENDS:=kmod-brcm-wl
+  DEPENDS:=@PACKAGE_kmod-brcm-wl||PACKAGE_kmod-brcm-wl-mimo +wireless-tools
   TITLE:=Broadcom wl wrapper module
   DESCRIPTION:=\
        This package contains a wrapper module, that provides Wireless Extension \\\
@@ -62,14 +62,14 @@ define Build/Compile
 endef
 
 define Package/kmod-wlcompat/install
-       install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
+       $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) $(PKG_BUILD_DIR)/wlcompat.o $(1)/lib/modules/$(LINUX_VERSION)/
-       install -d -m0755 $(1)/etc/modules.d
+       $(INSTALL_DIR) $(1)/etc/modules.d
        echo "wlcompat" > $(1)/etc/modules.d/30-wlcompat
 endef
 
 define Package/kmod-wlcompat-debug/install
-       install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
+       $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) $(PKG_BUILD_DIR)/wlcompat-debug.o $(1)/lib/modules/$(LINUX_VERSION)/
 endef