kernel: add missing kconfig symbol related to SSB
[openwrt/openwrt.git] / package / wpa_supplicant / Makefile
index a551c14e953201690d9e7a4b5cc81e55f670988a..0ad2ff31f8975f31fc0344f61d36a165b8dc8fc2 100644 (file)
@@ -1,21 +1,22 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wpa_supplicant
-PKG_VERSION:=0.6.3
-PKG_RELEASE:=1
-PKG_MD5SUM:=b51b2975f21006f85f7297f3fb1acde1
+PKG_VERSION:=0.6.9
+PKG_RELEASE:=2
+PKG_MD5SUM:=0efb8fcedf0a8acf6f423dfdb0658fdd
 
 PKG_SOURCE_URL:=http://hostap.epitest.fi/releases
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
+PKG_BUILD_DEPENDS:=PACKAGE_kmod-madwifi:madwifi
+
 include $(INCLUDE_DIR)/package.mk
 STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_kmod-madwifi CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK)
 
@@ -43,7 +44,7 @@ define Package/wpa-cli
 endef
 
 define Package/wpa-cli/Description
- WPA Supplicant control utility 
+ WPA Supplicant control utility
 endef
 
 CONFIG=$(firstword $(wildcard ./files/config.$(BOARD) ./files/config.$(ARCH) ./config))
@@ -73,6 +74,8 @@ define Package/wpa-supplicant/install
                $(PKG_BUILD_DIR)/wpa_supplicant/wpa_supplicant \
                $(PKG_BUILD_DIR)/wpa_supplicant/wpa_passphrase \
                $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/lib/wifi
+       $(INSTALL_DATA) ./files/wpa_supplicant.sh $(1)/lib/wifi/wpa_supplicant.sh
 endef
 
 define Package/wpa-cli/install