pass the CFLAGS through the environment on compile and fix a few packages
[openwrt/openwrt.git] / rules.mk
index 3afdab67c2822c4a3a2925c326ef580363dd7486..0a958c2d58688f3894835cb4da95ff619ce51bf1 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -69,6 +69,9 @@ ifneq ($(CONFIG_CCACHE),)
   TARGET_CC:= ccache $(TARGET_CC)
 endif
 
+EXTRA_CPPFLAGS := -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+EXTRA_LDFLAGS := -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+
 TARGET_CONFIGURE_OPTS:= \
   AR=$(TARGET_CROSS)ar \
   AS="$(TARGET_CC) -c $(TARGET_CFLAGS)" \