odhcpd: enable ipv6 server mode only when it is supported
[openwrt/openwrt.git] / rules.mk
index 38afc7777af5d9cd0ea89bb10dac89f0cf6ed067..6b881a0c619c11e63d7504b31e4c16f4271f81bc 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -391,8 +391,9 @@ endef
 
 # Calculate sha256sum of any plain file within a given directory
 # $(1) => Input directory
+# $(2) => If set, recurse into subdirectories
 define sha256sums
-       (cd $(1); find . -maxdepth 1 -type f -not -name 'sha256sums' -printf "%P\n" | sort | \
+       (cd $(1); find . $(if $(2),,-maxdepth 1) -type f -not -name 'sha256sums' -printf "%P\n" | sort | \
                xargs -r $(STAGING_DIR_HOST)/bin/mkhash -n sha256 | sed -ne 's!^\(.*\) \(.*\)$$!\1 *\2!p' > sha256sums)
 endef