do not set anything in DISABLE_IPV6 when set, let the package pick up the defaults
[openwrt/openwrt.git] / rules.mk
index 05609b9ac03afaec2df13fae2d1d214ec9f89ee1..88f64a5ebcdfc76bbf166a9a7e6df445791ecfba 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -153,13 +153,21 @@ else
 endif
 
 ifeq ($(CONFIG_ENABLE_LOCALE),true)
-  DISABLE_NLS:=
+  DISABLE_NLS:=--enable-nls
 else
   DISABLE_NLS:=--disable-nls
 endif
 
-ifneq ($(CONFIG_LARGEFILE),y)
-  DISABLE_LARGEFILE= --disable-largefile
+ifeq ($(CONFIG_IPV6),y)
+  DISABLE_IPV6:=
+else
+  DISABLE_IPV6:=--disable-ipv6
+endif
+
+ifeq ($(CONFIG_LARGEFILE),y)
+  DISABLE_LARGEFILE:=
+else
+  DISABLE_LARGEFILE:=--disable-largefile
 endif
 
 ifeq ($(CONFIG_TAR_VERBOSITY),y)