build: introduce extra targets that contain only proper dependencies
[openwrt/openwrt.git] / rules.mk
index e54acc9858287d3e0fba17c8c6ad4bb6c3914387..b42e19e21899bd3717e0a1f12d2d2ec27fe5ffd9 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -101,12 +101,13 @@ ifdef CONFIG_MIPS64_ABI
   endif
 endif
 
-DEFAULT_SUBDIR_TARGETS:=clean download prepare compile install update refresh prereq dist distcheck configure check
+DEFAULT_SUBDIR_TARGETS:=clean download prepare compile install update refresh prereq dist distcheck configure check check-depends
 
 define DefaultTargets
-$(foreach t,$(DEFAULT_SUBDIR_TARGETS),
-  $(t):
-  .PHONY: $(t)
+$(foreach t,$(DEFAULT_SUBDIR_TARGETS) $(1),
+  .$(t):
+  $(t): .$(t)
+  .PHONY: $(t) .$(t)
 )
 endef