kernel: Add support for XM25QH64A and XM25QH128A SPI NOR flash
[openwrt/openwrt.git] / scripts / checkpatch.pl
index 78053338c034f11242b9e5724e5b7e3e8e74d83d..5224ea49c3b27985c3d15928c2748467dce4fdd4 100755 (executable)
@@ -1,4 +1,4 @@
-#!/usr/bin/perl -w
+#!/usr/bin/env perl 
 # (c) 2001, Dave Jones. (the file handling bit)
 # (c) 2005, Joel Schopp <jschopp@austin.ibm.com> (the ugly bit)
 # (c) 2007,2008, Andy Whitcroft <apw@uk.ibm.com> (new conditions, test suite)
@@ -7,6 +7,7 @@
 # Licensed under the terms of the GNU GPL License version 2
 
 use strict;
+use warnings;
 
 my $P = $0;
 $P =~ s@.*/@@g;
@@ -391,7 +392,7 @@ sub top_of_openwrt_tree {
 
        my @tree_check = (
                "BSDmakefile", "Config.in", "LICENSE", "Makefile", "README",
-               "docs", "feeds.conf.default", "include", "package", "rules.mk",
+               "feeds.conf.default", "include", "package", "rules.mk",
                "scripts", "target", "toolchain", "tools"
        );