kernel: backport bgmac support for external PHYs
[openwrt/openwrt.git] / scripts / metadata.pm
index aa82fcd95d3189f871b87f71143557e90181487a..8334f26d3179a0eb83aa1aa976778ff5828faf45 100644 (file)
@@ -2,7 +2,7 @@ package metadata;
 use base 'Exporter';
 use strict;
 use warnings;
-our @EXPORT = qw(%package %srcpackage %category %subdir %preconfig %features %overrides clear_packages parse_package_metadata parse_target_metadata get_multiline);
+our @EXPORT = qw(%package %srcpackage %category %subdir %preconfig %features %overrides clear_packages parse_package_metadata parse_target_metadata get_multiline @ignore);
 
 our %package;
 our %preconfig;
@@ -11,6 +11,7 @@ our %category;
 our %subdir;
 our %features;
 our %overrides;
+our @ignore;
 
 sub get_multiline {
        my $fh = shift;
@@ -34,6 +35,7 @@ sub parse_target_metadata($) {
        my $file = shift;
        my ($target, @target, $profile);
        my %target;
+       my $makefile;
 
        open FILE, "<$file" or do {
                warn "Can't open file '$file': $!\n";
@@ -41,11 +43,13 @@ sub parse_target_metadata($) {
        };
        while (<FILE>) {
                chomp;
+               /^Source-Makefile: \s*((.+\/)([^\/]+)\/Makefile)\s*$/ and $makefile = $1;
                /^Target:\s*(.+)\s*$/ and do {
                        my $name = $1;
                        $target = {
                                id => $name,
                                board => $name,
+                               makefile => $makefile,
                                boardconf => confstr($name),
                                conf => confstr($name),
                                profiles => [],
@@ -64,7 +68,6 @@ sub parse_target_metadata($) {
                        }
                };
                /^Target-Name:\s*(.+)\s*$/ and $target->{name} = $1;
-               /^Target-Path:\s*(.+)\s*$/ and $target->{path} = $1;
                /^Target-Arch:\s*(.+)\s*$/ and $target->{arch} = $1;
                /^Target-Arch-Packages:\s*(.+)\s*$/ and $target->{arch_packages} = $1;
                /^Target-Features:\s*(.+)\s*$/ and $target->{features} = [ split(/\s+/, $1) ];
@@ -81,15 +84,19 @@ sub parse_target_metadata($) {
                        $profile = {
                                id => $1,
                                name => $1,
+                               priority => 999,
                                packages => []
                        };
+                       $1 =~ /^DEVICE_/ and $target->{has_devices} = 1;
                        push @{$target->{profiles}}, $profile;
                };
                /^Target-Profile-Name:\s*(.+)\s*$/ and $profile->{name} = $1;
+               /^Target-Profile-Priority:\s*(\d+)\s*$/ and do {
+                       $profile->{priority} = $1;
+                       $target->{sort} = 1;
+               };
                /^Target-Profile-Packages:\s*(.*)\s*$/ and $profile->{packages} = [ split(/\s+/, $1) ];
                /^Target-Profile-Description:\s*(.*)\s*/ and $profile->{desc} = get_multiline(*FILE);
-               /^Target-Profile-Config:/ and $profile->{config} = get_multiline(*FILE, "\t");
-               /^Target-Profile-Kconfig:/ and $profile->{kconfig} = 1;
        }
        close FILE;
        foreach my $target (@target) {
@@ -104,6 +111,11 @@ sub parse_target_metadata($) {
                                packages => []
                        }
                ];
+
+               $target->{sort} and @{$target->{profiles}} = sort {
+                       $a->{priority} <=> $b->{priority} or
+                       $a->{name} cmp $b->{name};
+               } @{$target->{profiles}};
        }
        return @target;
 }
@@ -127,6 +139,7 @@ sub parse_package_metadata($) {
        my $subdir;
        my $src;
        my $override;
+       my %ignore = map { $_ => 1 } @ignore;
 
        open FILE, "<$file" or do {
                warn "Cannot open '$file': $!\n";
@@ -152,6 +165,7 @@ sub parse_package_metadata($) {
                /^Package:\s*(.+?)\s*$/ and do {
                        undef $feature;
                        $pkg = {};
+                       $pkg->{ignore} = $ignore{$src};
                        $pkg->{src} = $src;
                        $pkg->{makefile} = $makefile;
                        $pkg->{name} = $1;
@@ -175,7 +189,7 @@ sub parse_package_metadata($) {
                $feature and do {
                        /^Target-Name:\s*(.+?)\s*$/ and do {
                                $features{$1} or $features{$1} = [];
-                               push @{$features{$1}}, $feature;
+                               push @{$features{$1}}, $feature unless $ignore{$src};
                        };
                        /^Target-Title:\s*(.+?)\s*$/ and $feature->{target_title} = $1;
                        /^Feature-Priority:\s*(\d+)\s*$/ and $feature->{priority} = $1;
@@ -216,7 +230,7 @@ sub parse_package_metadata($) {
                /^Build-Depends: \s*(.+)\s*$/ and $pkg->{builddepends} = [ split /\s+/, $1 ];
                /^Build-Depends\/(\w+): \s*(.+)\s*$/ and $pkg->{"builddepends/$1"} = [ split /\s+/, $2 ];
                /^Build-Types:\s*(.+)\s*$/ and $pkg->{buildtypes} = [ split /\s+/, $1 ];
-               /^Feed:\s*(.+?)\s*$/ and $pkg->{feed} = $1;
+               /^Repository:\s*(.+?)\s*$/ and $pkg->{repository} = $1;
                /^Category: \s*(.+)\s*$/ and do {
                        $pkg->{category} = $1;
                        defined $category{$1} or $category{$1} = {};
@@ -242,7 +256,7 @@ sub parse_package_metadata($) {
                                $preconfig = {
                                        id => $1
                                };
-                               $preconfig{$pkgname}->{$1} = $preconfig;
+                               $preconfig{$pkgname}->{$1} = $preconfig unless $ignore{$src};
                        }
                };
                /^Preconfig-Type:\s*(.*?)\s*$/ and $preconfig->{type} = $1;