Do not register more than 2 ethernet porst for CFE based devices (i.e : Compex WP54G...
[openwrt/openwrt.git] / target / Makefile
index 724ac4450d4bff3999b881da8fbbf20beb16b8ac..1b6cbb54ee1014e6f024f8c8fba6fe1e698fd6a9 100644 (file)
@@ -51,14 +51,4 @@ image_install: image_compile
 imagebuilder_install: image_install
        $(MAKE) -C imagebuilder install
 
-%-clean: FORCE
-       $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-download: FORCE
-       $(MAKE) -C $(patsubst %-download,%,$@) download
-%-prepare: FORCE
-       $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
-%-compile: %-prepare
-       $(MAKE) -C $(patsubst %-compile,%,$@) compile
-%-install: %-compile
-       $(MAKE) -C $(patsubst %-install,%,$@) install
-
+$(eval $(call default_subtargets,))