rename the Profile template that the image builder uses to prevent name conflicts...
[openwrt/openwrt.git] / target / imagebuilder / files / Makefile
index d4bcdf5fa93aa67f6112762adceba33ab2531aff..b36e2f2e31235308813a0ed781b8099a818b8ed5 100644 (file)
@@ -37,7 +37,7 @@ define Profile/Default
   PACKAGES:=
 endef
 
-define Profile
+define AddProfile
   $(eval $(call Profile/Default))
   $(eval $(call Profile/$(1)))
   ifneq ($(ID),)
@@ -47,7 +47,7 @@ define Profile
        $(ID)_NAME:=$(NAME)
        $(ID)_PACKAGES:=$(PACKAGES)
     PROFILE_LIST += \
-               echo '$(ID):'; echo '   $(NAME)';
+               echo '$(ID):'; [ -z '$(NAME)' ] || echo '       $(NAME)'; echo '        Packages: $(PACKAGES)';
   endif
 endef
 
@@ -87,6 +87,8 @@ $(TOPDIR)/tmp/ipkg.conf: FORCE
 
 BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $(PACKAGES) $($(PROFILE)_PACKAGES) kernel)
 BUILD_PACKAGES:=$(patsubst base-files,base-files-$(BOARD)-$(KERNEL),$(BUILD_PACKAGES))
+# "-pkgname" in the package list means remove "pkgname" from the package list
+BUILD_PACKAGES:=$(filter-out $(filter -%,$(BUILD_PACKAGES)) $(patsubst -%,%,$(filter -%,$(BUILD_PACKAGES))),$(BUILD_PACKAGES))
 
 image:
        if [ -z "$($(PROFILE)_NAME)" ]; then \
@@ -140,7 +142,7 @@ build_image: FORCE
        $(NO_TRACE_MAKE) -C target/linux/$(BOARD)-$(KERNEL)/image install IB=1
        
 clean:
-       rm -rf tmp $(TARGET_DIR)
+       rm -rf tmp $(TARGET_DIR) $(BIN_DIR)
 
 .PHONY: FORCE
 .SILENT: help info image