target: use SPDX license identifiers on Makefiles
[openwrt/openwrt.git] / target / linux / Makefile
index 8682fc2b9b07203bb191289b8cc55cba29cb5893..a939d42bc05463beaa0455b9ff5abc6c304ce2bd 100644 (file)
@@ -1,24 +1,11 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
+# SPDX-License-Identifier: GPL-2.0-only
 #
+# Copyright (C) 2006-2007 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
-download:
-       $(MAKE) -C $(BOARD)-$(KERNEL) download
-
-prepare:
-       rm -f $(TOPDIR)/.kernel.mk
-       $(MAKE) -C $(BOARD)-$(KERNEL) prepare
-
-compile:
-       $(MAKE) -C $(BOARD)-$(KERNEL) compile
+export TARGET_BUILD=1
 
-install:
-       $(MAKE) -C $(BOARD)-$(KERNEL) install
-       
-clean:
-       $(MAKE) -C $(BOARD)-$(KERNEL) clean
+prereq clean download prepare compile install oldconfig menuconfig nconfig xconfig update refresh: FORCE
+       @+$(NO_TRACE_MAKE) -C $(BOARD) $@