bump to 3.3.8
[openwrt/openwrt.git] / target / linux / adm5120 / Makefile
index 525636c733aa5ef05a56e45fde98338998acbc2b..273a2809391158ccd187d02900b1a171c9db1ed7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
-BOARDNAME:=Infineon ADM5120
-LINUX_VERSION:=2.6.23.11
-FEATURES:=squashfs jffs2 tgz broken
-SUBTARGETS:=router_le router_be
+BOARDNAME:=Infineon/ADMtek ADM5120
+LINUX_VERSION:=3.3.8
+SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += admswconfig
+DEFAULT_PACKAGES += admswconfig wpad-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
+                   kmod-leds-gpio kmod-ledtrig-adm5120-switch
 
 $(eval $(call BuildTarget))