octeon: remove linux 4.9 support
[openwrt/openwrt.git] / target / linux / adm8668 / Makefile
index 39d6c7f250d5b70f4efc27ce80371a8ab99184e7..cc82ec16064b017d08da1d4d39421fbdaff28204 100644 (file)
@@ -9,18 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=adm8668
 BOARDNAME:=Infineon WildPass ADM8668
-FEATURES:=squashfs
+FEATURES:=squashfs usb pci source-only
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.5
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += wpad-mini kmod-rt61-pci
-# kmod-switch kmod-diag nvram
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
        Build firmware images for Infineon WildPass (ADM8668) based routers
        (e.g. T-Mobile branded Linksys WRTU54G-TM)
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))