apm821xx: add support for the Cisco Meraki MR24
[openwrt/openwrt.git] / target / linux / ar7 / Makefile
index ff9ebe0ba42cb3f25c0bccc38672125638092137..1832e7b5e077d7dfb6eb598b56f9fa985d219af7 100644 (file)
@@ -1,5 +1,5 @@
-# Copyright (C) 2006-2009 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
-FEATURES:=squashfs jffs2 atm
+FEATURES:=squashfs atm low_mem
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+SUBTARGETS:=generic ac49x
 
-LINUX_VERSION:=2.6.32.16
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES+= kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl \
-               kmod-acx swconfig
+DEFAULT_PACKAGES+= swconfig
 
 define Target/Description
        Build firmware images for TI AR7 based routers.