ar71xx: fix the SingleProfile kernel size limit for dLAN devices
[openwrt/openwrt.git] / target / linux / ar71xx / Makefile
index 019e3cb13db98dc6c070e864e74e02588824ae06..24d7d5c692158c363a0691e29cf3ae736fef03c1 100644 (file)
@@ -9,17 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
-FEATURES:=squashfs targz mips16
+FEATURES:=mips16
 CPU_TYPE=34kc
-SUBTARGETS:=generic nand
+SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=3.10.17
+KERNEL_PATCHVER:=4.1
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
-       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
+       kmod-gpio-button-hotplug swconfig \
        kmod-ath9k wpad-mini uboot-envtools
 
 $(eval $(call BuildTarget))