build firmware image for the Atlantis-Land A02-RB-W300N
[openwrt/openwrt.git] / target / linux / ar71xx / Makefile
index 78ecd47df129203c8294c7ab11605d7de83db7dd..948c4615cf411e6f6b1753ada4683512ba50f532 100644 (file)
@@ -8,17 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx
+BOARDNAME:=Atheros AR71xx/AR913x
 FEATURES:=squashfs tgz
 
-LINUX_VERSION:=2.6.28.5
+LINUX_VERSION:=2.6.28.7
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
+DEFAULT_PACKAGES += \
+       kmod-gpio-leds kmod-input-core kmod-input-polldev \
+       kmod-input-gpio-buttons kmod-button-hotplug
 
 define Target/Description
-       Build firmware images for Atheros AR71xx based boards
+       Build firmware images for Atheros AR71xx/AR913x based boards.
 endef
 
 $(eval $(call BuildTarget))