ar71xx: add profile and build image for the WNR612 v2 board
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / netgear.mk
index fe136234f6f8abfd33cf928a38df8d65c4b44c7d..99425ec106de6ca4a3785f0b197bb9b8ae66600d 100644 (file)
@@ -1,10 +1,21 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
+define Profile/WNDAP360
+        NAME:=NETGEAR WNDAP360
+        PACKAGES:=
+endef
+
+define Profile/WNDAP360/Description
+        Package set optimized for the NETGEAR WNDAP360
+endef
+
+$(eval $(call Profile,WNDAP360))
+
 define Profile/WNDR3700
        NAME:=NETGEAR WNDR3700/WNDR3800/WNDRMAC
        PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev kmod-leds-wndr3700-usb
@@ -15,3 +26,37 @@ define Profile/WNDR3700/Description
 endef
 
 $(eval $(call Profile,WNDR3700))
+
+
+define Profile/WNDR4300
+       NAME:=NETGEAR WNDR4300
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WNDR4300/Description
+       Package set optimized for the NETGEAR WNDR4300
+endef
+
+$(eval $(call Profile,WNDR4300))
+
+
+define Profile/WNR2000V3
+       NAME:=NETGEAR WNR2000V3
+endef
+
+define Profile/WNR2000V3/Description
+       Package set optimized for the NETGEAR WNR2000V3
+endef
+
+$(eval $(call Profile,WNR2000V3))
+
+
+define Profile/WNR612V2
+       NAME:=NETGEAR WNR612V2
+endef
+
+define Profile/WNR612V2/Description
+       Package set optimized for the NETGEAR WNR612V2
+endef
+
+$(eval $(call Profile,WNR612V2))