ar71xx: create profile and build image for the OpenMesh MR900 board
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / openmesh.mk
index 2f33d83c3e60d7b3688864682d87c8bce1c03ba5..6f714d5f3f280eeaaeb308983c7c9a7b33f557d1 100644 (file)
@@ -16,6 +16,17 @@ endef
 
 $(eval $(call Profile,OM2P))
 
+define Profile/OM5P
+       NAME:=OpenMesh OM5P
+       PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/OM5P/Description
+       Package set optimized for the OpenMesh OM5P.
+endef
+
+$(eval $(call Profile,OM5P))
+
 define Profile/MR600
         NAME:=OpenMesh MR600
         PACKAGES:=kmod-ath9k om-watchdog
@@ -27,6 +38,17 @@ endef
 
 $(eval $(call Profile,MR600))
 
+define Profile/MR900
+        NAME:=OpenMesh MR900
+        PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/MR900/Description
+        Package set optimized for the OpenMesh MR900.
+endef
+
+$(eval $(call Profile,MR900))
+
 define Profile/OPENMESH
        NAME:=OpenMesh products
        PACKAGES:=kmod-ath9k om-watchdog