ar71xx: create profile and build image for the OpenMesh MR900 board
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / openmesh.mk
index 53ae5987f999e7b3b27a79712839d2dd270442a7..6f714d5f3f280eeaaeb308983c7c9a7b33f557d1 100644 (file)
@@ -6,16 +6,27 @@
 #
 
 define Profile/OM2P
-       NAME:=OpenMesh OM2P/OM2P-HS/OM2P-LC
+       NAME:=OpenMesh OM2P/OM2Pv2/OM2P-HS/OM2P-HSv2/OM2P-LC
        PACKAGES:=kmod-ath9k om-watchdog
 endef
 
 define Profile/OM2P/Description
-       Package set optimized for the OpenMesh OM2P/OM2P-HS/OM2P-LC.
+       Package set optimized for the OpenMesh OM2P/OM2Pv2/OM2P-HS/OM2P-HSv2/OM2P-LC.
 endef
 
 $(eval $(call Profile,OM2P))
 
+define Profile/OM5P
+       NAME:=OpenMesh OM5P
+       PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/OM5P/Description
+       Package set optimized for the OpenMesh OM5P.
+endef
+
+$(eval $(call Profile,OM5P))
+
 define Profile/MR600
         NAME:=OpenMesh MR600
         PACKAGES:=kmod-ath9k om-watchdog
@@ -27,6 +38,17 @@ endef
 
 $(eval $(call Profile,MR600))
 
+define Profile/MR900
+        NAME:=OpenMesh MR900
+        PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/MR900/Description
+        Package set optimized for the OpenMesh MR900.
+endef
+
+$(eval $(call Profile,MR900))
+
 define Profile/OPENMESH
        NAME:=OpenMesh products
        PACKAGES:=kmod-ath9k om-watchdog