ar71xx: add profile and build image for the TL-WA7510N board
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index 23e6b96e2e540c295c899fe2f453b19b22fa85db..07d7059a8c0de8b14a832c9580da8df6565599fd 100644 (file)
@@ -82,6 +82,16 @@ define Profile/TLWA701/Description
 endef
 $(eval $(call Profile,TLWA701))
 
+define Profile/TLWA7510
+       NAME:=TP-LINK TL-WA7510N
+       PACKAGES:=
+endef
+
+define Profile/TLWA7510/Description
+       Package set optimized for the TP-LINK TL-WA7510N.
+endef
+$(eval $(call Profile,TLWA7510))
+
 
 define Profile/TLWA901
        NAME:=TP-LINK TL-WA901N/ND
@@ -95,12 +105,12 @@ $(eval $(call Profile,TLWA901))
 
 
 define Profile/TLWDR4300
-       NAME:=TP-LINK TL-WDR4300
+       NAME:=TP-LINK TL-WDR3600/4300/4310
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLWDR4300/Description
-       Package set optimized for the TP-LINK TL-WDR4300.
+       Package set optimized for the TP-LINK TL-WDR3600/4300/4310.
 endef
 $(eval $(call Profile,TLWDR4300))